Back to overview
Downtime
Leaderboard is currently down
Feb 19 at 08:20pm AKST
Resolved
Feb 19 at 11:15pm AKST
Leaderboard has been restored. Thank you for your patience.
Affected services
Updated
Feb 19 at 09:54pm AKST
Hosting provider is aware of the issue and is working on it.
Affected services
Created
Feb 19 at 08:20pm AKST
We are aware the Leaderboard App is currently experiencing loading issues. We believe this is a related server issue with our hosting provider and will update this as soon as more information is available.
Affected services